En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.
 
 
 
 
 
 
 
Vous êtes ici :   Accueil » Faire tourner Guppy avec EasyPhp

Webmaster - Infos

Préférences


Se reconnecter :
Votre nom (ou pseudo) :
Votre mot de passe


  2077642 visiteurs
  5 visiteurs en ligne

  34 membres
Connectés :
membresAUBERT_HENRI
membresHenri
    Imprimer la page...
    Imprimer la section...

Faire tourner Guppy avec EasyPhp

Faire tourner Guppy avec EasyPHP 1.8 (OBSOLETE)

  1.  Télécharger EasyPHP 1.8 à cette adresse :
    https://sourceforge.net/project/showfiles.php?group_id=14045
    et Installez le sur votre PC. (Ne pas se tromper de version, bien choisir la V1.8).
     
  2.  Téléchargez Guppy.zip (Actuellement, Guppy 4.6.9) à cette adresse :
     
  3.  Décompressez Guppy.zip avec votre programme de décompression favori (WinZip, UltimateZip, SevenZip...) dans un dossier Guppy de votre PC, préalablement créé dans le Dossier "Mes Documents" par exemple.
     
  4.  Copiez tout le contenu de ce Guppy décompressé dans le sous-répertoire :
    www de EasyPHP1_8, précédemment installé ( C:Program Files/EasyPHP1_8/www/Guppy469/
     
  5.  Guppy peut bien fonctionner avec Easyphp 1.8 à condition de rétablir les paramètres qui ont changés par rapport à la version 1.6 avec laquelle GuppY fonctionnait très bien.
    Ces paramètres sont aux nombres de deux. Ce sont : register_globals et error_reporting.
    Pour les modifier, il faut éditer le fichier nommé php.ini que l'on trouve (sous WindowsXP) dans le dossier Program files/easyphp1-8/apache.
     
  6.    Par mesure de sécurité, faites une sauvegarde de ce fichier avant de le modifier.   
     
  7. Ouvrez php.ini avec le bloc note, ou mieux,
    avec Sc_Html, téléchargé et installé précedemment.(Eventuellement, il est encore temps de le faire en cliquant sur son Nom).
     
  8.   Allez à la ligne 390, intitulée :
    "register_globals = Off", et remplacez-la par "register_globals = On
     
  9.    Allez à la ligne 287, intitulée ";error_reporting = E_ALL & ~E_NOTICE" et supprimez le point-virgule qui se trouve devant, afin d'activer cette ligne. Vous obtenez donc "error_reporting = E_ALL & ~E_NOTICE".
     
  10.    Allez à la ligne 295, intitulée "error_reporting = E_ALL" et ajoutez un point-virgule juste devant pour désactiver cette ligne. Vous obtenez donc ";error_reporting = E_ALL" .
     
  11.  Il faudra également modifier la ligne 1091 en supprimant le « ; » devant la ligne

    extension=php_gd2.dll

    Cette modif servira à l’occasion pour « Uploader » des Images sur votre Site en ligne.

     

  12.  Sauvegardez vos modifications.
     
  13. Normalement si les modifications ont été faites correctement, il sera possible d'utiliser Easyphp 1.8 pour utiliser GuppY en local. 
     
  14.  Ouvrez votre dossier Guppy en double cliquant sur : Poste de Travail, puis :
    C:Program/Files/EasyPHP1-8/www/Guppy645/
     
  15. Recopier le contenu de l'URL qui se trouve dans la barre adresse,
     
  16. Ouvrez le menu d'administration de EasyPhp (Clic droit sur le E de EasyPhp dans la barre du systray en bas à droite de votre écran),
     
  17. Cliquer sur l'icône "Ajouter", à droite de l'icône de Dossier dans la Module "Apache",
     
  18. Coller le contenu du presse papier en "ligne 2 (Saisir un Nom pour l'alias)" et en ligne  "ligne 3 (Saisir le chemin du répertoire créé (ex.: C:web/localsites/site1)"
     
  19. Dans la ligne 2, supprimer tout ce qui se trouve avant Guppy,
     
  20. Cliquer sur "OK" en ligne 5,
     
  21. Cliquer sur :"Cliquer sur redémarrer et attendre que apache et mysql repassent au vert dans le statut, 
     
     L'Interface de EasyPHP étant ouverte, GuppY est prêt à fonctionner en local sur votre PC !
    Il suffit de Cliquer sur le lien nouvellement créé, par exemple :
    Guppy465.
     
    BRAVO, le plus dur est fait tongue tongue tongue
    On va pouvoir s'attaquer à la construction de notre Site Guppy. cool

Faire tourner Guppy avec EasyPHP- Devserver-16.1.1 (ACTUEL)

Nous sommes en Novembre 2016, Le PHP a évolué ainsi que Guppy qui est maintenant à la version 5.01.05

Pour faire tourner Guppy, il faut maintenant un serveur local au moins en PHP5.4.

"EasyPhp-DevServer-16.1.1" est le serveur local qu'il vous faut.

Pour le télécharger :

https://www.easyphp.org/save-easyphp-devserver-latest.php?d=direct

Voir la rubrique "Administrer Guppy en local"


Date de création : 11/10/2007 - 12:53
Dernière modification : 08/03/2019 - 16:37
Catégorie : -
Page lue 11777 fois


Réactions à cet article


Personne n'a encore laissé de commentaire.
Soyez donc le premier !

Derniers Messages de mon Forum PhpBB3

forum.gif

Lire la suite

Derniers Messages de mon Livre d'or Alex_GuestBook

livredor.gif

Utilisateur de Guppy, je suis membre de l'association "FreeGuppy", et vous ???



ban_asso_rv.gif

Lire la suite

livredor.gif

Utilisateur de Guppy, je suis membre de l'association "FreeGuppy", et vous ???



ban_asso_rv.gif

Fermer

Le Vide-grenier de Henri Chéli

houa.gif

Devant l'abondance de matériel informatique récupéré çà et là, et remis en état,

j'ai décidé d'ouvrir un Vide Grenier.

C'est aussi une façon pour moi de faire l'inventaire de mes trésors. smile

N'hésitez pas à vous renseigner.

Mise à jour du Plugin "QuickCart V5" en V6.7 par "Linuxmr" le 19/03/2018

Ce Plugin "Boutique", remis à jour par LINUXMR est à nouveau disponible en V6.01 depuis le 14 Janvier 2019

vide-grenier.jpg>

Cliquez là ou ci-dessous, ou dans le Menu  nouveau4.gif

Lire la suite

houa.gif

Devant l'abondance de matériel informatique récupéré çà et là, et remis en état,

j'ai décidé d'ouvrir un Vide Grenier.

C'est aussi une façon pour moi de faire l'inventaire de mes trésors. smile

N'hésitez pas à vous renseigner.

Mise à jour du Plugin "QuickCart V5" en V6.7 par "Linuxmr" le 19/03/2018

Ce Plugin "Boutique", remis à jour par LINUXMR est à nouveau disponible en V6.01 depuis le 14 Janvier 2019

vide-grenier.jpg>

Cliquez là ou ci-dessous, ou dans le Menu  nouveau4.gif

Fermer

Guppy 5.02.02 et Nouveautés magiques

Guppy 5.02.02

guppy.gif

Et voici Guppy 5.0.0.2, la 100ème version de Guppy. Dans quelques jours, Guppy aura 15 ans. La première version de miniPortail est sortie le 30 décembre 2002. Pour cette 100ème version, deux nouveautés importantes font leur apparition.

- l'intégration du plugin jQuery Unite-Gallery, y compris la partie administration.

- l'intégration du plugin jQuery Liquid Slider, y compris la partie administration.

Un grand "Bravo" à "Saxbar", à Papinou et à la "GuppyTeam" pour toutes ces nouveautés.

Unite-Gallery

photo.gif

Unite Gallery est un plugin jQuery responsive, pour des galeries de photos et de vidéos. Cette galerie puissante et rapide, a toutes les fonctionnalités nécessaires, responsive, réactive au toucher et même un effet zom.
Responsive - s'adapte à chaque écran avec préservation automatique du ratio et peut répondre à un changement de taille d'écran.
Toucher - Toutes les parties de la galerie peuvent être contrôlées par des dispositifs tactiles.
Skinnable - Possibilité de changer de skins avec facilité dans différents fichiers css sans toucher la galerie principale css.
Thèmes - plusieurs thèmes, chaque thème a ses propres options et fonctionnalités, mais il utilise les objets de base de la galerie.
Effet Zoom - un effet zoom unique qui peut-être appliqué à l'intérieur des boutons, de la molette de la souris ou d'un geste de pincement au toucher.
Thème Vidéo - à partir de : Youtube, Vimeo, HTML5, Wistia.

Liquid Skidery

ordinateur.pngsmartphone.pngtablettes.png

Liquid Slider est un Slider jQuery Responsive, ce qui sous-entend créer dans le but de s'adapter à tous les terminaux et par conséquent aux différentes tailles d'écran.

Il présente des transitions CSS3, utilise "animate.css", la navigation dynamique par glisser-déplacer, et plus encore.

Puissant, facile à utiliser et rapide.

Il est entièrement réactif et totalement adaptable aux changements de largeur et d'orientation, utilisant des animations CSS3 modernes pour forcer l'acquisition matérielle sur les périphériques mobiles, vous n'aurez jamais à vous soucier des transitions lentes ou rapides.