Vous êtes ici :   Accueil »
    Imprimer la page...
 
 

Nouvelles

news1.gifVers le Php5.3 - le 19/10/2010 - 17:27 par Henri
Vers le PHP 5.3
 
Mon site étant maintenant hébergé en PHP 5.2.13, je vise dans un 1er temps, la compatibilité PHP 5.3.0 et je me suis rendu compte que certains Plugins posaient encore des problèmes avec les fameuses fonctions "deprecated", en clair, obsolètes.  cheeky

Je les ai identifié en les éliminant les uns après les autres sur un serveur EasyPhp 5.2 et PHP 5.3. et les ai modifié, ils étaient passés au travers de mes modifs précédentes.

Je n'avais pas non plus solutionné le fonctionnement du Plugin "Cinéma", en fait, il n'est plus compatible PHP 5, la fonction "include une URL extérieure" n'existe plus pour des raisons de sécurité. 
Je me suis "inspiré du Plugin "Programmes TV" et j'ai remplacé "l'include" par une "Iframe" et.... et ... ça fonctionne.
yes
Je vais maintenant m'attaquer à la compatibilité PHP 5.3.3 qui est la dernière connue.

Affaire à suivre ....

Lire la suite